Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Bienvenue Guest!

Rejoignez la communauté pour avoir accès à l'entièreté du site! Une fois que vous serez enregistré, vous pourrez créer, aider, partager et discuter avec les membres de la communauté et également participer à l'amélioration du site. Alors, qu'attendez vous ? Enregistrez-vous !

  • 0
Seishin

résolu Problème esx_jb_advanced_truck_inventory

Question

Seishin

image.thumb.png.cf9f1fa9d2348e221ed48778e0cda90b.png

Quel OS utilisez vous sur votre machine ? : En local et sous linux

Chez quel hébergeur êtes-vous ? : Microserum
Sur quel framework travaillez vous? (ESX/VRP/ES/Autre) : ESX

Quel est le script que vous utilisez (+version)? : esx_jb_advanced_truck_inventory
Qu'avez vous-essayé auparavant ? (Vider votre cache, installation du script au propre etc...): mettre in item dans un coffre
Êtes vous sûr d'avoir la dernière version de votre framework ? : oui

Explication de votre problème : Bonjour, J'ai un soucis avec esx_jb_advanced_truck_inventory j'ai cette erreur qui apparaît lorsque j'appuis sur la touche qui doit normalement ouvrir le coffre mais rien ne se passe et cette erreur apparaît je ne comprend pas pourquoi puisque je n'ai rien touché coter client si ce n'ai que la touche merci d'avance aux personnes qui m'aideront.

Lien vers vos logs de l'erreur sur pastebin/hastebin client+serveur : l'image plus haut

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1
Kanda Sorata

Essai de remplacer ce bout de code : (L.146 du client)

if lastVehicle > 0 then
      	SetVehicleDoorShut(lastVehicle, 5, false)
		local lastvehicleplatetext = GetVehicleNumberPlateText(lastVehicle)
		TriggerServerEvent('esx_truck_inventory:RemoveVehicleList', lastvehicleplatetext)
      	lastVehicle = 0
end

par celui ci :

if lastVehicle ~= nil then
	if lastVehicle > 0 then
      SetVehicleDoorShut(lastVehicle, 5, false)
      local lastvehicleplatetext = GetVehicleNumberPlateText(lastVehicle)
      TriggerServerEvent('esx_truck_inventory:RemoveVehicleList', lastvehicleplatetext)
      lastVehicle = 0
	end
end

Ca t'affiche cette erreur lorsque tu n'as pas de véhicules en face de toi, il essai de récupérer un véhicule qui n'a pas de valeur (nil) et ensuite de le comparer à un nombre, là on vérifie d'abord si ce n'est pas nil, et si il n'est pas nil, on le compare alors avec un nombre

Share this post


Link to post
Share on other sites
  • 0
Kanda Sorata

Bonjour, merci de suivre le modèle de demande d'aide ici :

 

Share this post


Link to post
Share on other sites
  • 0
Seishin

C'est bon j'ai edit

Share this post


Link to post
Share on other sites
  • 0
Kanda Sorata

As tu essayé sur un véhicule d'abord ? Car là actuellement il n'y a rien en face de toi

Share this post


Link to post
Share on other sites
  • 0
Seishin

Oui mais même si je le fait 1 fois dans le vide après je n'ai plus accès au coffre ça ne met même plus le petit message en bas a gauche "Aucun véhicule a proximité"

Share this post


Link to post
Share on other sites
  • 0
Seishin

Enfaîte des fois ça marche et d'un coup ça marque cette erreur je ne sais pas pourquoi bizarre

Share this post


Link to post
Share on other sites
  • 0
Seishin

ça a l'air de marché merci

Share this post


Link to post
Share on other sites
  • 0
Kanda Sorata

Niquel pas de soucis 👍 Je lock :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

En utilisant ce site, vous acceptez les présents règlements Terms of Use, Privacy Policy,Guidelines.