Aller au contenu
Rechercher dans
  • Plus d’options…
Rechercher les résultats qui contiennent…
Rechercher les résultats dans…
  • 0
jaYs

résolu Sauvegarde des positions des joueurs à la déconnexion

Question

jaYs

Salut à tous,

 

Je suis nouveau dans la gestion de serveur FiveM. Je ne touche pas du tout au language .lua.
Je connais un peu le php et mysql.

 

Je cherche à sauvegarder la position des joueurs à leur déconnexion. J'ai pourtant installé ES extended et tous modes qui vont avec mais cela ne fonctionne pas. Systématiquement quand les joueurs se connectent, vont au spawn que j'ai introduit dans hipster/skater. 

 

J'ai cherché des scripts sur le forum FiveM mais ils ne fonctionnent pas, peut-être dû à un conflit quelconque. 

 

Pourriez-vous m'aider ?

 

Merci d'avance pour votre aide précieuse.

Modifié par jaYs

Partager ce message


Lien à poster
Partager sur d’autres sites

12 réponses à cette question

Messages recommandés

  • 0
Kanda Sorata

Bonjour, ESX gère nativement ceci, soyez sur de l'avoir correctement installé

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
jaYs

Merci du retour.
J'ai suivi le tuto à la lettre. Je ne sais pas où j'aurais pu me planter.
Serait-il possible qu'un conflit avec une autre ressource l'empêche de fonctionner?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Kanda Sorata

Non, pas de conflit possible, sauf si deux versions différentes de esx sont mises, ou alors deux frameworks différents démarrer en même temps, regardez si vous n'avez pas des erreurs côtés clients et/ou serveur

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
jaYs

Honnêtement, je sèche.

J'ai remis tout de base, vidé la bdd, tout réinstallé. Même chose...
Dans ma table SQL, les positions se savent mais lorsque je me reco, ça spawn aléatoirement comme s'il n'y avait rien.

 

start mapmanager
start chat
start spawnmanager
start sessionmanager
restart sessionmanager
start fivem
start hardcap
start rconlog
#start scoreboard
start async
start skinchanger
start z-loadscreen
start disabledispatch
start FireScript
start speedometer
start DiscordWhitelist
start discord_perms
start vmenu
start vk_handsup
start indicators
start not_steal
start fivem-ipl

###################### Set connection MYSQL-async
set mysql_connection_string "mysql://esx_user:****@localhost/esx?dateStrings=true"
 
###################### Disable Couchdb from essentialmode
set es_enableCustomData 1

start mysql-async

# ES resources
add_ace resource.essentialmode command.sets allow
add_ace resource.essentialmode command.add_principal allow
add_ace resource.essentialmode command.add_ace allow

# ES Base
start essentialmode
start esplugin_mysql
start es_admin2

# ESX Extended
start es_extended
start esx_menu_default
start esx_menu_list
start esx_menu_dialog

Une idée?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
James Trema

Bonjour,

 

Dans ton sql dans ta table user ensuite structure tu est à 255 ? on ses jamais, bonne journée

Capture.PNG

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
jaYs

Salut James!

Merci pour ton message.

Après avoir vérifié, mon varchar est en 36. Je ne connais pas ce que cela change mais visiblement ça doit avoir une incidence si tu m'en fais part.

Je testerai ça dès que possible et je ferai un retour.

Merci beaucoup.

Screenshot_20190527_090149.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Kanda Sorata

Bonjour non, aucune incidence là dessus, le 36 est juste la limite de caractères dans valeur position

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
jaYs

Donc bredouille.

Je vais refaire une installation propre et tester à nouveau...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Kanda Sorata

Vérifiez également que vous n'avez pas d'erreurs dans vos consoles (serveur + client)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
jaYs

Après plusieurs manipulation, j'ai enfin réussi à faire fonctionner le module.

Merci pour vos pistes !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Kanda Sorata

Pas de soucis, je verrouille le sujet alors !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
JagerBom
Le 05/06/2019 à 12:42, jaYs a dit :

Après plusieurs manipulation, j'ai enfin réussi à faire fonctionner le module.

Merci pour vos pistes !

 

J'ai déverrouiller le sujet, car comme ça tu peux mettre ce que tu as fais pour que cela refonctionne. Comme ça ça servira a d'autres peut-être. merci de la contribution. Apres on relock le sujet.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...

Information importante

En utilisant ce site, vous acceptez les présents règlements Conditions d’utilisation, Politique de confidentialité,Règles.