Aller au contenu
Rechercher dans
  • Plus d’options…
Rechercher les résultats qui contiennent…
Rechercher les résultats dans…
Bienvenue Invité!

Rejoignez la communauté pour avoir accès à l'entièreté du site! Une fois que vous serez enregistré, vous pourrez créer, aider, partager et discuter avec les membres de la communauté et également participer à l'amélioration du site. Alors, qu'attendez vous ? Enregistrez-vous !

  • 0
zouki

résolu RageMP linux server problème

Question

zouki

Bonjour a tous, dans un premier temps merci de me lire voici plus de présicion.

 

OS: Debian 8, Debian 9, Ubuntu

Technologie: RageMP v0.37 (linux)

 

Ce que j'ai essayer de faire:

J'ai installer NodeJS 10 & 11 (Release), Mais aussi Mono project.

J'ai suivie a la lettre: https://wiki.rage.mp/index.php?title=Getting_Started_with_Server#Debian

j'ai aussi essayer avec les deb de debian 9 sur Debian 8.

pour Ubuntu j'ai aussi suivie le wiki de RageMP https://wiki.rage.mp/index.php?title=Getting_Started_with_Server#Ubuntu

 

J'ai aussi tenté avec Docker sans-succès.

 

sur différents port:

dans un premier temps sur les port: 22005 (UDP) & 22006 (TCP)

et ensuite pensant que le problème pouvait venir des port j'ai essayer sur les port 17005 (UDP) & 17006 (TCP)

Problèmes:

 

une fois connecter au serveur dans le chat serveur j'ai le message qui tourne en boucle 'Can't join server, trying again.'

 

quelqu'un aurait t-il une approximation ou un hypothèse s'il vous plait ?

Modifié par zouki

Partager ce message


Lien à poster
Partager sur d’autres sites

5 réponses à cette question

Messages recommandés

  • 0
zouki
Il y a 3 heures, JagerBom a dit :

 

essaye de faire cette commande:

 

service apache2 restart

apres cela c'est pour restart apache (port 80) apres je sais pas si cela va changer quelque chose... l'ouverture des ports m'y connais pas super bien nonplus :')

Je n'utilise pas apache, mais merci tout de même je tien une piste avec les iptables

 

 

Mise jours 17h40:

Finalement j'ai utilisé `ufw` créer les règles du trafic sur ma machine.

J'ai ouvert les port pour la connexion ssh (22).

ainsi que les port 22005 & 22006

$ ufw allow 22005
$ ufw allow 22006
$ ufw reload

Capture.JPG.bfe19c8c85f13a959db41e274035e1d0.JPG

ensuite j'ai utilisé ce site pour scanner mes ports:

https://portscanner.standingtech.com/

 

Capture.thumb.JPG.830f8bf6972549d539aad31116907950.JPGCapture2.thumb.JPG.d1a9709b3f2abe6d770ad116f8e3c6ca.JPG

Modifié par zouki

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 1
JagerBom

tes ports sont ouvert ?

 

met ton ip et port ici sur le site et il t'indiquera si tes ports sont ouverts ou pas 

https://www.yougetsignal.com/tools/open-ports/

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
zouki
il y a 21 minutes, JagerBom a dit :

tes ports sont ouvert ?

 

met ton ip et port ici sur le site et il t'indiquera si tes ports sont ouverts ou pas 

https://www.yougetsignal.com/tools/open-ports/

 

Merci de m'accorder du temps :)
Alors après scan mes port 22005 & 22006 sont bien fermée.


me sembler les avoir ouvert avec https://www.tixati.com/optimize/open-ports-linux.html, mais sa n'a pas l'air de fonctionner.

soit j'ouvre pas correctement les port soit la commandes iptables ne fonctionne pas correctement sous Debian 9. j'ai rédémarrer la machine entre temps pour m'assurer que sa applique les modifications mais rien n'y fait.

 

 

Capture.JPG

Modifié par zouki

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
JagerBom
Il y a 1 heure, zouki a dit :

 

Merci de m'accorder du temps :)
Alors après scan mes port 22005 & 22006 sont bien fermée.


me sembler les avoir ouvert avec https://www.tixati.com/optimize/open-ports-linux.html, mais sa n'a pas l'air de fonctionner.

soit j'ouvre pas correctement les port soit la commandes iptables ne fonctionne pas correctement sous Debian 9. j'ai rédémarrer la machine entre temps pour m'assurer que sa applique les modifications mais rien n'y fait.

 

 

Capture.JPG

 

essaye de faire cette commande:

 

service apache2 restart

apres cela c'est pour restart apache (port 80) apres je sais pas si cela va changer quelque chose... l'ouverture des ports m'y connais pas super bien nonplus :')

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
JagerBom

je clos le sujet car résolut 😛

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...

Information importante

En utilisant ce site, vous acceptez les présents règlements Conditions d’utilisation, Politique de confidentialité,Règles.